Как подсчитать уникальные значения в Excel

Excel

Хотите найти количество уникальных значений в наборе данных Excel? Вы можете подсчитывать уникальные значения в Excel несколькими способами. Это руководство объяснит, как это сделать.

Глядя на электронную таблицу Excel, может быть сложно. Все значения могут сливаться в одно, что затрудняет поиск нужных данных.

Программы для Windows, мобильные приложения, игры - ВСЁ БЕСПЛАТНО, в нашем закрытом телеграмм канале - Подписывайтесь:)

Вот почему важно знать, как вы можете анализировать свои данные. Например, вам может понадобиться узнать, сколько повторяющихся чисел есть в диапазоне ячеек или сколько уникальных чисел.

Если вы хотите узнать, как подсчитывать уникальные значения в Excel, выполните следующие действия.

Как быстро подсчитать значения в Excel

Вам нужен способ быстро подсчитать количество значений в наборе данных в Excel? Для ясности: это общее количество значений, а не уникальных значений.

Если вам нужно знать только число (но вы не хотите взаимодействовать с ним в электронной таблице), есть быстрый способ проверить. Для этого выберите ячейки, содержащие ваши значения в электронной таблице.

Выбрав ячейки, взгляните на нижнюю часть окна Excel (под метками листов). Вы увидите различные расчеты для вас, включая количество значений. Это подсчитывает количество непустых ячеек.

Быстрый подсчет значений в диапазоне ячеек в Excel

Хотя это не позволяет вам подсчитать количество уникальных значений, оно предлагает быстрый способ проверить, сколько из ваших ячеек имеют значение, а сколько нет.

Как подсчитать уникальные значения в Excel, используя СУММПРОИЗВ и СЧЁТЕСЛИ

Если вы хотите подсчитать уникальные значения в Excel, лучший способ сделать это — использовать формулу. Для этого можно использовать комбинацию функций СУММ и СЧЁТЕСЛИ.

Чтобы быстро объяснить, что делают эти функции, СУММПРОИЗВ умножит, а затем вернет сумму диапазона данных. COUNTIF подсчитает количество ячеек в диапазоне, соответствующих условию. Вы можете использовать обе функции вместе, чтобы вернуть количество уникальных значений для каждой ячейки в массиве.

Например, если у вас есть список чисел от одного до восьми, но число восемь повторяется дважды, возвращаемый массив будет содержать значение 1, а не восьмерку, где будет возвращено значение 2. Это связано с тем, что значение 8 повторяется дважды.

Чтобы подсчитать уникальные значения в Excel, используя СУММПРОИЗВ и СЧЁТЕСЛИ:

  1. Откройте электронную таблицу Excel.
  2. Выберите пустую ячейку рядом с вашим набором данных, убедившись, что столбец, в котором он находится, пуст.
  3. В строке формул введите следующую формулу: =СУММПРОИЗВ(1/СЧЁТЕСЛИ(диапазон,диапазон)) при замене обоих значений диапазона диапазоном ячеек, содержащим ваши данные. (например, =СУММПРОИЗВ(1/СЧЁТЕСЛИ(A2:A8;A2:A8))).
  4. Нажмите Enter — формула вернет общее количество уникальных значений в диапазоне ячеек.
    Вычисление общего количества уникальных значений в диапазоне ячеек в Excel

Как подсчитать уникальные значения в Excel с помощью сводной таблицы

Другой способ подсчета уникальных значений в Excel — использование сводной таблицы. Это позволяет более тщательно анализировать данные.

Чтобы подсчитать уникальные значения в Excel с помощью сводной таблицы:

  1. Откройте электронную таблицу Excel.
  2. Выберите свои данные.
  3. Нажмите «Вставка» > «Сводная таблица».
    Вставка сводной таблицы в Excel
  4. Выбранный диапазон данных уже должен отображаться в качестве критериев в окне параметров сводной таблицы. Выберите, хотите ли вы добавить сводную таблицу на новый рабочий лист или на существующий рабочий лист.
  5. Обязательно установите флажок Добавить эти данные в модель данных.
  6. Нажмите OK, чтобы вставить сводную таблицу.
    Настройка параметров сводной таблицы в Excel
  7. В меню «Поля сводной таблицы» выберите столбец, содержащий данные, которые вы хотите проанализировать.
  8. В разделе «Значения» нажмите существующую опцию и выберите «Настройки поля значений».
    Настройка сводной таблицы в Excel
  9. Прокрутите список и выберите опцию Distinct Count.
  10. Нажмите ОК.
    Настройка сводной таблицы в Excel

Сводная таблица обновится, чтобы показать вам общее количество уникальных значений в вашем наборе данных.

Использование сводной таблицы для расчета количества уникальных значений в наборе данных Excel

Вы можете настроить свою сводную таблицу, чтобы изменить это дальше. Например, вы можете разбить это значение, используя подкатегории, в зависимости от того, как ваши данные расположены в электронной таблице.

Вычисление значений в Microsoft Excel

Используя приведенные выше шаги, вы можете быстро подсчитать уникальные значения в Excel. Это всего лишь один из способов использования Excel для расчета, обработки и анализа различных значений. Например, вы можете захотеть рассчитать процентное увеличение или уменьшение с помощью Excel, что идеально подходит для вашего финансового планирования.

В Excel есть и другие формулы, которые вы можете использовать, от основных формул, таких как SUM, до более сложных формул, таких как TRUNC. Если вы новичок в Excel, не забудьте ознакомиться с этими важными советами по Excel, чтобы начать работу.

Программы для Windows, мобильные приложения, игры - ВСЁ БЕСПЛАТНО, в нашем закрытом телеграмм канале - Подписывайтесь:)

Похожие записи

Добавить комментарий

Ваш адрес email не будет опубликован.